Главная » Софт » Тестовая сборка Android P намекает на возможную несовместимость с старым ПО

Тестовая сборка Android P намекает на возможную несовместимость с старым ПО

Проблема совместимости старого программного обеспечения с актуальной версией операционной системы может дать о себе знать при переходе на новую мобильную платформу от Google, проходящую под рабочим названием Android P. В теме на Reddit указывается, что дистрибутив для разработчиков Android P Developer Preview уведомляет о возможных проблемах в работоспособности устаревших версий программ в новом окружении.  

Минимально допустимый уровень API для сборки Android P Developer Preview равен v17, что соответствует Android 4.2. Таким образом приложения, ориентированные на более низкий уровень API, использовать в грядущей версии мобильной ОС попросту не выйдет ввиду установленных разработчиками технических ограничений.  

Для решения указанной проблемы Google в своём сообщении предлагает обратиться к авторам софта за технической поддержкой — выпуском апдейта для обеспечения необходимой совместимости.

Операционная система Android P всё ещё находится в стадии разработки, следовательно, подобного рода ограничения к финальному релизу могут быть пересмотрены и скорректированы. Не исключено, что предупреждение носит сугубо информационный характер, намекая на использование ну очень старой версии программного обеспечения. Так что говорить о масштабной чистке Google Play от приложений, не попадающих в рамки по указанному критерию, пока рано.  

Источник:

Если вы заметили ошибку — выделите ее мышью и нажмите CTRL+ENTER.
Материалы по теме